If you are experiencing an issue not reflected on this page, or require help, please contact our support team directly by emailing support@tracr.com.
Resolved
GIA site maintenance is now completed and the issue is resolved.
Identified
Problem: The link to the GIA Report Check is not working as expected.
Impact: Users are unable to access the GIA report check via the provided link, without having to manually search for the Report number.
Causes: The provider, GIA, has confirmed the issue is due to their ongoing site maintenance.
Steps to resolve: GIA has confirmed their site maintenance will be completed this week, which will resolve the issue.