If you are experiencing an issue not reflected on this page, or require help, please contact our support team directly by emailing support@tracr.com.
Resolved
This issue has been resolved.
Monitoring
A fix has been implemented.
We are actively monitoring the situation to ensure stability.
Identified
We have identified the issue and are now implementing a fix.
Investigating
The platform is experiencing some slowness when processing rough check requests.
Our engineering team is investigating and will provide an update shortly.