Tracr Portal and ticketing system login issues
Resolved·Full outage

This issue has been resolved.

Fri, Dec 5, 2025, 12:40 PM
(17 hours ago)
·
Affected components
Tracr Portal
Updates

Resolved

This issue has been resolved.

Fri, Dec 5, 2025, 12:40 PM

Monitoring

All components are operational.

We are actively monitoring the situation to ensure stability.

Fri, Dec 5, 2025, 09:22 AM(3 hours earlier)

Monitoring

Our Tracr Portal and Ticketing system has been briefly impacted due to 3rd party failure.

Please be aware that tickets can be also raised by sending an email to support@tracr.com

A fix has been implemented and we are actively monitoring the situation to ensure stability.

Fri, Dec 5, 2025, 09:18 AM
Powered by

If you are experiencing an issue not reflected on this page, or require help, please contact our support team directly by emailing support@tracr.com.