Slowness when processing rough check requests
Resolved·Degraded performance

This incident has been resolved. The fix has been effective, and platform performance has remained stable. Thank you for your patience.

Wed, Sep 24, 2025, 10:39 AM
(2 months ago)
·
Affected components
Rough Check
Updates

Resolved

This incident has been resolved. The fix has been effective, and platform performance has remained stable. Thank you for your patience.

Wed, Sep 24, 2025, 10:39 AM

Monitoring

We experienced slowness on the platform when processing rough check requests. Our engineering team has released a fix, and performance should now be improved.
We are actively monitoring the situation to ensure stability.

Wed, Sep 17, 2025, 03:45 PM(6 days earlier)

Identified

The new requests are now being processed without delays.
The team is working on fixing few pending requests submitted at the beginning of the incident.

Wed, Sep 17, 2025, 10:11 AM(5 hours earlier)

Investigating

The platform is experiencing some slowness when processing rough check requests.
Our engineering team is investigating and will provide an update shortly.

Wed, Sep 17, 2025, 08:38 AM(1 hour earlier)
Powered by

If you are experiencing an issue not reflected on this page, or require help, please contact our support team directly by emailing support@tracr.com.